piątek, 4 lutego 2011

Konstrukcja domku dla lalek.

UWAGA !!! Powstał nowy blog w którym opisuje aktualny stan prac nad domkiem.


Konstrukcja domku dla lalek została wykonana ze sklejki. Mam na razie ściany z balkonami. Brakuje ścian działowych, dachu oraz ściany tylniej.

Pierwsze podejście …

Pierwsze podejście do wykonania mebelków dla lalek – łóżeczko ze sklejki. Łóżeczko ma 12 cm długości i 6 cm szerokości.

Microsoft Vista, wirus oraz tcpip.sys.

Znajoma przywiozła laptopa, w którym system operacyjny Vista nie startował i zatrzymywał się na komunikacie o braku możliwości zweryfikowaniu podpisu cyfrowego sterownika tpcip.sys. Przy starcie systemu trzeba było wcisnąć F8 i wybrać opcję „Wyłącz sprawdzenie podpisu cyfrowego sterownika”. Vista startowała, pojawiał się pulpit i wyskakiwał program Antivirus8 i wyrzucał dużo wirusów w całym komputerze a na koniec generował pseudo BSOD 0x000000a, zrzucał pamięć i resetował komputer. Combofix nie działał, antywirusy nie działały itp. Wyciągnąłem dysk twardy i przez kieszeń USB wpiąłem do innego komputera. Sprawdziłem dysk antywirusem AVG, który usunął pseudoprogram antywirusowym.
Po wpięciu dysku z powrotem do laptopa ponownie pojawił się problem z podpisem sterownika. Ponownie obszedłem problem przez wyłączenie opcji sprawdzania poprawności. System wystartował ale nie pojawił się pulpit. Uruchomienie explorer.exe kończyło się błędem o braku pliku lub ścieżki do pliku. Podmiana explorera z service packa nic nie dawało, wyłączenie sprawdzania podpisu poleceniem:
bcdedit /set loadoptions DISABLE_INTEGRITY_CHECKS
nie przynosiło skutku. Rozwiązaniem okazała się podmiana uszkodzonego sterownika tcpip.sys, który okazał się wirusem i zawsze startował z systemem operacyjnym (w załączniku plik z mojej Visty). Podmianę pliku wykonałem mając twardy dysk z laptopa w kieszeni USB. Po tej operacji Vista wystartowała bez pulpitu, ale wywołanie poleceniem explorera przywróciło pulpit i system zaczął pracować poprawnie.

Dell D610, Intel PROSet/Wireless, iwpdgina.dll i panel logowania.

Po zainstalowaniu Intel PROSet/Wireless do obsługi karty bezprzewodowej zmienił mi się panel logowania i zniknęło przełączanie użytkowników w Dell’u D610 z systemem XP. Przy próbie zmiany panelu w ustawieniach użytkowników wyskakiwał komunikat z błędem wskazujący na plik iwpdgina.dll. Rozwiązanie znalazłem przez forum Asusa. Należy pobrać plik XP_FixLogon.exe ze strony Doug Knox i uruchomić go. Po restarcie komputera panel logowania powraca na swoje miejsce. Winne całemu zamieszaniu jest oprogramowanie bezprzewodowej karty sieciowej, w moim przypadku konieczne, ponieważ standardowy klient sieci bezprzewodowych Windows XP nie potrafił podłączyć laptopa do żadnej sieci.

Windows 2000 i obsługa dysków powyżej 137 GB.

Instalowałem windows 2000 na dysku 500 GB. W czasie instalacji windows widział tylko 137 GB, również po instalacji wielkość dysku nie zmieniła się. Instalowany system był wraz z service pack 4. Rozwiązanie znalazłem na stronie Microsoftu. W skrócie należy:
  • uruchomić edytor rejestru: start->uruchom
  • regedit
  • w edytorze rejestru odszukać:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\atapi\Parameters
  • jeżeli jest wartość: EnableBigLba należy ustawić ją na 1
  • jeżeli nie ma tej wartości:
    należy dodać za pomocą: menu->edycja dodaj wartość DWORD
    Nazwa wartości: EnableBigLba
    Dane wartości: 0×1
W moim przypadku należało dodać nowy wpis.

Toshiba L300 i BSOD 0×00000024 & 0×00008086

Trafił do mnie laptop Toshiba L300, który sypał błędem 0×00000024. W podobnym przypadku podanym w tym wątku wystarczyło sprawdzić dysk pod kątem błędów poleceniem „chkdsk”. W tym przypadku rozpocząłem poszukiwania od sprawdzenia S.M.A.R.T.’u dysku. Odczyt parametrów w/w pokazał problem – bad sectory (3 były już przeniesione). Pozostało wykonanie testu powierzchni dysku programem MHDD zawartym na płycie UBCD. Pierwsze bady zaczęły pojawiać się po około 200 MB. W tym momencie zaprzestałem testów i zaleciłem wymianę dysku twardego (marka Hitachi). Największą niewiadomą było, czy odzyska się partycję Recovery z systemem Vista, ponieważ właścicielka laptopa nie miała nagranych płyt recovery. Po zakupie dysku 320 GB rozpocząłem wykonywanie kopii 1:1 – po sektorowej uszkodzonego dysku. Na początku chciałem wykorzystać program HDDClone, ale dowiedziałem się, że nie radzi sobie dobrze z bad sectorami. Kolejnym softem był DMDE pod Windows. Ta wersja wieszała się trafiając na zły sektor. Rozwiązaniem okazał się DMDE pod DOS utworzony wg. opisu Migol21. W trakcie trafienia na bad sector należy odznaczyć ilość prób z 2 na 0 i odhaczyć czekanie na decyzję użytkownika. Cały proces trwał około 3 godzin i zakończył się powodzeniem. Można było odzyskać system z partycji recovery oraz stworzyć płyty z systemem Vista.
Wnioski: Pamiętaj Polaku młody zanim zaczniesz naprawiać system sprawdź stan dysku twardego.

Zupa gulaszowa po mojemu.

Po wakacjach i obiadach w Neptunie naszły mnie smaki na zupę gulaszową. Moja zupa wygląda tak:
1/2 kg łopatki,
1 duża cebula,
1 mała marchew,
1 średnia papryka,
sól, pieprz (do smaku).
Jako, że w mojej rodzinie paprykę jadam tylko ja, więc cała gulaszowa jest dla mnie. Na początku mięso przesmażam z cebulką tak do przypalenia cebuli. Później dodaję wodę i gotuję mięso jak na gulasz. W trakcie gotowania dodaję marchew i paprykę, gotuję wszystko do miękkości, doprawiam solą i pieprzem, zagęszczam śmietaną lub mąką. Po prostu pychotka :).

Dziwne zdjęcie zrobione manualem.

czwartek, 3 lutego 2011

Kaktus zakwitł dwoma kwiatami.

Jak co roku jedyny kaktus jaki kwitnie w mojej kolekcji zakwitł. Trochę pogoda mu nie sprzyja, ale dwa piękne duże kwiaty ma.







Pilot antyk :).

Do sprawdzenia był pilot antyk.


Pilot nie działał. Jego konstrukcja była prosta. Naprawę rozpocząłem od wymiany wszystkich gumek. Pilot zaczął działać, ale diody nadawcze działały coraz słabiej, aż w końcu przestał działać ponownie. Rozwiązaniem problemu było usunięcie zimnych lutów na diodach nadawczych.

DVD Samsung DVD-P171 nie czyta płyt.

Dostałem do sprawdzenia DVD Samsunga DVD-P171. Odtwarzacz nie czytał wszystkich płyt. Naprawę rozpocząłem od wyczyszczenia izopropanolem soczewki lasera. Po załączeniu DVD okazało się, że ma ono problem z sterowaniem, załączaniem itp. Dokonałem pomiaru napięć wg. schematu DVD-P171. Na przetwornicy wszystkie napięcia były w normie. W tym poście wyczytałem, że te odtwarzacze mają problem z napięciem 3,3V – po przesłaniu go 20 cm kabelkiem na płytkę procesora DVD spada ono do poziomu 2,8V. Skorzystałem z zaleceń kolegi z w/w postu i zrobiłem dodatkowy kabelek pomiędzy JP12 płytki przetwornicy a rezystorem zerowym zabezpieczającym napięcie 3,3V. Efekt DVD ożyło, reaguje na przyciski, odtwarza płyty DVD. Zdjęcie poniżej obrazuje wpięcie (niestety jest ruszone).

Windows XP i BSOD 0×00000024.

Dostałem komputer aby zainstalować system Windows XP bo poprzedni system wysypał się.  Idąc na łatwiznę trzeba by było odzyskać pliki osobiste właściciela komputera i format c: :).
Rozpatrując problem bardziej profesjonalnie i jak się okazuje mniej pracochłonne trzeba znaleźć przyczynę „wysypania” się XP. W moim przypadku XP uruchamiał się do pewnego momentu i restartował komputer. Przy starcie komputera wciskamy F8 i  wybieramy opcję „Wyłącz automatyczne ponowne uruchamianie po awarii systemu”.  W momencie, kiedy wcześniej komputer restartował się, zobaczymy  BSOD w moim przypadku 0×00000024. Informacja ze strony Microsoftu częściowo naprowadza na rozwiązanie problemu. Należy uruchomić instalator Windows XP, wybrać opcję „Naprawy systemu” ( opcja „R” ) i przejrzeć dysk pod kątem błędów czyli „chkdsk /P”. W przypadku tego komputera sprawdzenie dysku pod kątem błędów rozwiązało problem, system uruchomił się poprawnie. Przed jakimikolwiek działaniami przydało by się sprawdzić stan dysku twardego w programie MHDD.

Windows 98 i brak Internetu/sieci Lan.

Ostatnio miałem taki problem z siecią:


Na komputerach z Windows XP było wszystko OK.
Na komputerze z Windows 98 nie było Internetu oraz były problemy z dostępem do sieci. Komputer pobierał adres z serwera DHCP, innym razem przydzielał sobie adres prywatny. Pingi docierały do serwera raz po 1 ms, innym razem po 700 ms a w większości prób pingi traciły się. Wymienię w punktach co robiłem, co nie przyniosło pozytywnego rozwiązania sprawy:
  • zmiana portu w switchu, reset switcha,
  • wypięcie pozostałych komputerów ze switcha,
  • wymiana kabla A,
  • wymiana karty sieciowej w komp. 98,
  • ustawienie statycznego adresu IP na komp. 98,
  • podmiana switcha,
  • wymiana kabla B,
  • sprawdzenie komputera pod kątem wirusów,
  • reset oraz zmiana portu w switchu poprzedającym,
… i na końcu wymiana gniazdka … i wszystko na komputerze z Win 98 ruszyło. Jak dla mnie kapitalna zagadka – ze względu na to, że na pozostałych komputerach sieć działała cały czas.

Po kilku miesiącach problem pojawił się ponownie i znowu po wielu kombinacjach wyszło, że płyta musi mieć konflikt z kartami sieciowymi oraz Win98.